1+X 云计算平台运维与开发认证(初级)样卷B

单选题(200分)
1
下面哪个不是项目开发成员角色?(10分)

A、项目经理 

B、测试经理

C、产品经理

D、实施经理 (正确答案)

2
为满足金融业务的监管和安全要求,平台不需要考虑下列哪个应用?(10分)

A、文档版本管理 (正确答案)

B、防火墙策略

C、安全漏洞扫描

D、多租户安全隔离

教师点评:
此题还没有任何教师进行点评~
3
SVN全称Subversion,即?(10分)

A、版本控制系统 (正确答案)

B、项目实施系统

C、测试开发系统

D、设计管理系统

教师点评:
此题还没有任何教师进行点评~
4
以下哪一个是收尾过程的正确顺序?(10分)

A、得到正式验收、解散团队、写出经验教训、结束合同

B、写出经验教训、解散团队、得到正式验收、结束合同

C、得到正式验收、写出经验教训、解散团队、结束合同 (正确答案)

D、得到正式验收、结束合同、写出经验教训、解散团队

教师点评:
此题还没有任何教师进行点评~
5
下面关于交换型以太网说法正确的是?(10分)

A、各独立网段是被隔离的 (正确答案)

B、站点数越多,平均带宽越小

C、收到CSMA/CD的约束

D、覆盖范围受到碰撞域的限制

教师点评:
此题还没有任何教师进行点评~
6
子网掩码为255.255.255.0,下列哪个IP地址和其余的不在同一网段中?(10分)

A、172.16.32.55

B、172.16.25.44 (正确答案)

C、172.16.32.201

D、172.16.32.12

教师点评:
此题还没有任何教师进行点评~
7
VLAN基本上可以看成是一个?(10分)

A、局域网

B、广播域 (正确答案)

C、工作站

D、广域网

教师点评:
此题还没有任何教师进行点评~
8
下列选项当中,不属于FTP服务的使用者是?(10分)

A、本地用户

B、虚拟用户

C、匿名用户

D、远程用户 (正确答案)

教师点评:
此题还没有任何教师进行点评~
9
文件权限读、写、执行三种符号的标志依次是?(10分)

A、rwx (正确答案)

B、xrw

C、rdx

D、rws

教师点评:
此题还没有任何教师进行点评~
10
下列选项中不是局域网的以太网标准的是?(10分)

A、802.3

B、802.4

C、802.5

D、801.2 (正确答案)

教师点评:
此题还没有任何教师进行点评~
11
分布式系统由多台计算机组成,它们在地域上是?(10分)

A、分散的 (正确答案)

B、聚合的

C、独立的

D、互联的

教师点评:
此题还没有任何教师进行点评~
12
Nginx服务使用什么语言编写?(10分)

A、C语言 (正确答案)

B、JAVA

C、python

D、PHP

教师点评:
此题还没有任何教师进行点评~
13
在主从数据库的哪种模式下,部分slave的数据同步不连接主节点,而是连接从节点?(10分)

A、级联复制 (正确答案)

B、一主双从

C、双主双从

D、级联复制、双主双从

教师点评:
此题还没有任何教师进行点评~
14
在使用命令上传一个glance镜像到OpenStack平台的时候,需要配置镜像格式为qcow2,使用的相应参数是?(10分)

A、--container-format

B、--containers-format

C、--disk-format (正确答案)

D、--disks-format

教师点评:
此题还没有任何教师进行点评~
15
Ceilometer服务将监控到的数据存储到哪里?(10分)

A、MySQL数据库

B、MongoDB数据库 (正确答案)

C、Swift对象存储

D、Hbase数据库

教师点评:
此题还没有任何教师进行点评~
16
Neutron服务可以向OpenStack平台提供各种不同的网络,下列哪种网络不属于Neutron服务能提供的网络?(10分)

A、BGP (正确答案)

B、vlan

C、GRE

D、vxlan

教师点评:
此题还没有任何教师进行点评~
17
VPC 的公共子网是一个?(10分)

A、 在其关联的路由表中至少有一个使用 Internet 网关(IGW)的路由。 (正确答案)

B、 通过网络地址转换(NAT)实例在其关联的路由表中包含路由。

C、 有一个网络访问控制列表(NACL)允许出站流量到 0.0.0.0/0。

D、 在其配置中选择了公共子网选项。

教师点评:
此题还没有任何教师进行点评~
18
Amazon S3 存储桶提供以下哪项? (10分)

A、 为新对象的放置编写一致性,并与 POST & DELETES 保持一致

B、 为新对象的 POST 编写一致性,并最终为覆盖和删除一致

C、 重新编写新对象的一致性,并最终与覆盖和删除一致 (正确答案)

D、 重新编写新对象的后写一致性,并与 POST & DELETES 保持一致

教师点评:
此题还没有任何教师进行点评~
19
一个EC2实例可以连接多少个EBS卷?(10分) (答案未做:0分)

A、1

B、2

C、27 (正确答案)

D、无限

教师点评:
此题还没有任何教师进行点评~
20
下列选项当中,哪个是Dockerfile中FROM指令的含义(10分)

A、为镜像指定标签

B、运行指定命令

C、容器启动时要运行的命令

D、指定基础镜像 (正确答案)

教师点评:
此题还没有任何教师进行点评~
多选题(300分)
21
白盒技术主要包括?(15分) (答案未做:0分)

A、语句覆盖 (正确答案)

 B、判定覆盖 (正确答案)

 C、条件覆盖 (正确答案)

 D、逻辑覆盖 (正确答案)

教师点评:
此题还没有任何教师进行点评~
22
在容器平台中,日志大致分为环境日志和应用日志,下面日志中属于环境日志的有?(15分)

A、业务应用日志

 B、容器运行日志 (正确答案)

 C、宿主机容器引擎日志 (正确答案)

 D、容器平台管理日志 (正确答案)

教师点评:
此题还没有任何教师进行点评~
23
项目从开始到结束的若干阶段构成了项目的生命周期,下面哪些是项目生命周期阶段?(15分)

A、实施阶段 (正确答案)

 B、终止阶段

 C、概念阶段 (正确答案)

 D、计划阶段 (正确答案)

教师点评:
此题还没有任何教师进行点评~
24
交换机的主要功能有哪些?(15分)

 A、环路避免 (正确答案)

 B、路由转发

 C、转发\过滤 (正确答案)

 D、地址学习 (正确答案)

教师点评:
此题还没有任何教师进行点评~
25
VLAN划分方式有哪些?(15分)

 A、基于路由转发方式

 B、基于策略方式 (正确答案)

 C、基于服务需求方式

 D、基于MAC地址方式 (正确答案)

教师点评:
此题还没有任何教师进行点评~
26
Samba服务所需软件包括哪些?(15分)

A、Samba (正确答案)

 B、Samba-smbd

 C、Samba-client (正确答案)

 D、Samba-common (正确答案)

教师点评:
此题还没有任何教师进行点评~
27
NFS由下列那几个部分组成?(15分)

A、NFS内核模块 (正确答案)

 B、NFS用户空间工具 (正确答案)

 C、RPC相关服务 (正确答案)

 D、HDFS相关服务

教师点评:
此题还没有任何教师进行点评~
28
下面那些是主从数据的优点?(15分)

A、方便做数据的热备份 (正确答案)

 B、架构的扩展更容易 (正确答案)

 C、读写分离,使数据库能支撑更大的并发 (正确答案)

 D、加快读写速度

教师点评:
此题还没有任何教师进行点评~
29
下面选项当中,哪些是私有云平台分类?(15分)

 A、私有云平台 (正确答案)

 B、私有云服务 (正确答案)

 C、私有云建设平台

 D、私有云管理平台 (正确答案)

教师点评:
此题还没有任何教师进行点评~
30
下列选项当中,不是说明Swift组件作用的是?(15分)

A、用于提供镜像服务 (正确答案)

 B、用于提供对象存储功能

 C、用于提供计量与监控功能 (正确答案)

 D、用于提供编排服务或功能 (正确答案)

教师点评:
此题还没有任何教师进行点评~
31
在下列选项当中,属于Mysql特点的有哪些?(15分)

A、性能卓越、服务稳定 (正确答案)

 B、成本低、支持多种操作系统 (正确答案)

 C、对流行的PHP语言无缝支持 (正确答案)

 D、非关系型数据库

教师点评:
此题还没有任何教师进行点评~
32
以下选项的组合可以保护 S3 对象免于意外删除和意外覆盖?(15分)

A、在存储桶上启用 S3 版本控制。 (正确答案)

 B、只使用签名的网址访问 S3 数据。

 C、使用 IAM 桶策略禁用 S3 删除。

 D、启用多因素身份验证(MFA)保护的访问。 (正确答案)

教师点评:
此题还没有任何教师进行点评~
33
亚马逊的EBS卷为?(15分)

A、基于块的存储 (正确答案)

 B、基于对象的存储

 C、默认基于磁盘

 D、提供各种SSD和磁性选件 (正确答案)

教师点评:
此题还没有任何教师进行点评~
34
AWS如何允许您将元数据添加到EC2实例?(15分)

 A、证书 (正确答案)

 B、标签 (正确答案)

 C、政策

 D、标签

教师点评:
此题还没有任何教师进行点评~
35
以下哪项是存储网关的有效选项?(15分)

A、文件网关 (正确答案)

 B、卷网关 (正确答案)

 C、缓存的网关

 D、虚拟专用网关

教师点评:
此题还没有任何教师进行点评~
36
哪些是VPC端点类型?(15分)

A、接口端点 (正确答案)

 B、对等端点

 C、网关端点 (正确答案)

 D、服务端点

教师点评:
此题还没有任何教师进行点评~
37
以下哪项提供了自动备份RDS数据库的方法?(15分)

 A、自动快照 (正确答案)

 B、 S3生命周期管理策略

 C、自动备份 (正确答案)

 D、数据管道

教师点评:
此题还没有任何教师进行点评~
38
以下哪些是SSD支持的卷的特征?(15分)

A、事务性工作量 (正确答案)

 B、流工作负载

 C、Small I / O Size (正确答案)

 D、以吞吐量为中心

教师点评:
此题还没有任何教师进行点评~
39
Docker容器有几种状态?(15分)

A、运行 (正确答案)

 B、已暂停 (正确答案)

 C、重新启动 (正确答案)

 D、已退出 (正确答案)

教师点评:
此题还没有任何教师进行点评~
40
下列选项当中,哪些不是K8S查看Deployment列表的命令?(15分)

A、kubectl show deployment (正确答案)

 B、kubectl get deployment

 C、kubectl display deployment (正确答案)

 D、kubectl check deployment (正确答案)

教师点评:
此题还没有任何教师进行点评~
实操题(500分)
网络管理(20分)
41

通过一条命令在S1交换机(交换机使用S5700)上创建vlan100、vlan101,配置vlan100网关为:172.16.100.254/24。配置vlan101网关为:172.16.101.254/24。配置g0/0/1端口为trunk模式,放行vlan100。配置g0/0/2端口为access模式,所属vlan101。将以上所有操作命令和返回结果以文本形式提交大答题框。

参考答案:

[SW1]vlan batch 100 101
[SW1]interface Vlanif 100
[SW1-Vlanif100]ip address 172.16.100.254 24
[SW1]interface Vlanif 101
[SW1-Vlanif101]ip address 172.16.101.254 24
[SW1]interface GigabitEthernet 0/0/1
[SW1-GigabitEthernet0/0/1]port link-type trunk
[SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 100
[SW1-GigabitEthernet0/0/1]quit
[SW1]interface GigabitEthernet 0/0/2
[SW1-GigabitEthernet0/0/2]port link-type access
[SW1-GigabitEthernet0/0/2]port default vlan 101
[SW1-GigabitEthernet0/0/2]quit

网络管理(30分)
42

配置路由器R1(路由器使用AR2220)端口g0/0/1地址为192.168.101.1/30,配置g0/0/2端口地址为12.12.12.2/30。添加静态路由去往192.168.1.0/24网段,下一跳地址为192.168.101.2,添加静态路由去往192.168.2.0/24,下一跳地址为12.12.12.1。将以上所有操作命令和返回结果以文本形式提交到答题框。

参考答案:

[R1]interface GigabitEthernet 0/0/1
[R1-GigabitEthernet0/0/1]ip address 192.168.101.1 30
[R1-GigabitEthernet0/0/1]quit
[R1]interface GigabitEthernet 0/0/2
[R1-GigabitEthernet0/0/2]ip address 12.12.12.2
[R1-GigabitEthernet0/0/2]quit
[R1]ip route-static 192.168.1.0 24 192.168.101.2
[R1]ip route-static 192.168.2.0 24 12.12.12.1

本地YUM源管理(20分)
43

使用VMWare软件启动提供的xserver1虚拟机(配置虚拟机xserver1的IP为192.168.100.11,主机名为xserver1),在虚拟机的/root目录下,存在一个CentOS-7-x86_64-DVD-1511.iso的镜像文件,使用这个镜像文件配置本地yum源,要求将这个镜像文件挂载在/opt/centos目录,请问如何配置自己的local.repo文件,使得可以使用该镜像中的软件包,安装软件。请将local.repo文件的内容以文本形式提交到答题框。

参考答案:

[centos]
name=centos
baseurl=file:///opt/centos
gpgcheck=0
enabled=1

FTP安装使用(20分)
44

使用xserver1虚拟机,安装ftp服务,并配置ftp的共享目录为/opt。使用VMWare软件继续启动提供的xserver2虚拟机(配置虚拟机xserver2的IP为192.168.100.12,主机名为xserver2),并创建该虚拟机的yum源文件ftp.repo使用xserver1的ftp源(配置文件中的FTP地址使用主机名)。配置完成后,将xserver2节点的ftp.repo文件以文本形式提交到答题框。

参考答案:

[centos]
name=centos
baseurl=ftp://xserver1/centos
gpgcheck=0
enabled=1

Samba管理(30分)
45

使用xserver1虚拟机,安装Samba服务所需要的软件包,将xserver1节点中的/opt/share目录使用Samba服务共享出来(目录不存在请自行创建)。操作完毕后,将xserver1节点Samba配置文件中的[share]段落和执行netstat -ntpl命令的返回结果以文本形式提交到答题框。

参考答案:

[share]
path = /opt/share
browseable = yes
public = yes
writable = yes
[root@samba ~]# netstat -ntpl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN 2718/smbd
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1469/sshd
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2168/master
tcp 0 0 0.0.0.0:445 0.0.0.0:* LISTEN 2718/smbd
tcp6 0 0 :::139 :::* LISTEN 2718/smbd
tcp6 0 0 :::22 :::* LISTEN 1469/sshd
tcp6 0 0 ::1:25 :::* LISTEN 2168/master
tcp6 0 0 :::445 :::* LISTEN 2718/smbd

主从数据库管理(40分)
46

在xserver1、xserver2上安装mariadb数据库,并配置为主从数据库(xserver1为主节点、xserver2为从节点),实现两个数据库的主从同步。配置完毕后,请在xserver2上的数据库中执行“show slave status \G”命令查询从节点复制状态,将查询到的结果以文本形式提交到答题框。

参考答案:

MariaDB [(none)]> start slave;
MariaDB [(none)]> show slave status\G
*************************** 1. row ***************************
Slave_IO_State: Waiting for master to send event
Master_Host: mysql1
Master_User: user
Master_Port: 3306
Connect_Retry: 60
Master_Log_File: mysql-bin.000003
Read_Master_Log_Pos: 245
Relay_Log_File: mariadb-relay-bin.000005
Relay_Log_Pos: 529
Relay_Master_Log_File: mysql-bin.000003
Slave_IO_Running: Yes
Slave_SQL_Running: Yes
Replicate_Do_DB:
Replicate_Ignore_DB:
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table:
Last_Errno: 0
Last_Error:
Skip_Counter: 0
Exec_Master_Log_Pos: 245
Relay_Log_Space: 1256
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: No
Master_SSL_CA_File:
Master_SSL_CA_Path:
Master_SSL_Cert:
Master_SSL_Cipher:
Master_SSL_Key:
Seconds_Behind_Master: 0
Master_SSL_Verify_Server_Cert: No
Last_IO_Errno: 0
Last_IO_Error:
Last_SQL_Errno: 0
Last_SQL_Error:
Replicate_Ignore_Server_Ids:
Master_Server_Id: 30
1 row in set (0.00 sec)

LNMP环境部署(40分)
47

使用xserver1节点,安装单节点lnmp环境。安装lnmp环境需要用到的YUM源为CentOS-7-x86_64-DVD-1511.iso和lnmp目录(均在/root目录下)。安装并配置完lnmp环境后。依次查询数据库、nginx、php服务的状态,并使用netstat -ntpl命令查看端口开放情况。最后依次将查询服务状态的返回结果,和查看端口开放情况的返回结果以文本形式提交到答题框。

参考答案:

[root@localhost ~]# systemctl status mariadb
● mariadb.service - MariaDB database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
Active: active (running) since Fri 2019-12-06 12:29:37 EST; 56s ago
Process: 2741 ExecStartPost=/usr/libexec/mariadb-wait-ready $MAINPID (code=exited, status=0/SUCCESS)
Process: 2713 ExecStartPre=/usr/libexec/mariadb-prepare-db-dir %n (code=exited, status=0/SUCCESS)
Main PID: 2740 (mysqld_safe)
CGroup: /system.slice/mariadb.service
├─2740 /bin/sh /usr/bin/mysqld_safe --basedir=/usr
└─2897 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin --log-error=/var/log/mariadb/mariadb.log --pid-file=/var/run/mariadb/ma...
Dec 06 12:29:34 localhost.localdomain systemd[1]: Starting MariaDB database server...
Dec 06 12:29:34 localhost.localdomain mysqld_safe[2740]: 191206 12:29:34 mysqld_safe Logging to '/var/log/mariadb/mariadb.log'.
Dec 06 12:29:34 localhost.localdomain mysqld_safe[2740]: 191206 12:29:34 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
Dec 06 12:29:37 localhost.localdomain systemd[1]: Started MariaDB database server.
[root@localhost ~]# systemctl status nginx
● nginx.service - nginx - high performance web server
Loaded: loaded (/usr/lib/systemd/system/nginx.service; disabled; vendor preset: disabled)
Active: active (running) since Fri 2019-12-06 12:29:54 EST; 46s ago
Docs: http://nginx.org/en/docs/
Process: 2945 ExecStart=/usr/sbin/nginx -c /etc/nginx/nginx.conf (code=exited, status=0/SUCCESS)
Main PID: 2946 (nginx)
CGroup: /system.slice/nginx.service
├─2946 nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf
└─2947 nginx: worker process
Dec 06 12:29:54 localhost.localdomain systemd[1]: Starting nginx - high performance web server...
Dec 06 12:29:54 localhost.localdomain systemd[1]: PID file /var/run/nginx.pid not readable (yet?) after start.
Dec 06 12:29:54 localhost.localdomain systemd[1]: Started nginx - high performance web server.
[root@localhost ~]# systemctl status php-fpm
● php-fpm.service - The PHP FastCGI Process Manager
Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; disabled; vendor preset: disabled)
Active: active (running) since Fri 2019-12-06 12:30:00 EST; 59s ago
Main PID: 2953 (php-fpm)
Status: "Processes active: 0, idle: 5, Requests: 0, slow: 0, Traffic: 0req/sec"
CGroup: /system.slice/php-fpm.service
├─2953 php-fpm: master process (/etc/php-fpm.conf)
├─2955 php-fpm: pool www
├─2956 php-fpm: pool www
├─2957 php-fpm: pool www
├─2958 php-fpm: pool www
└─2959 php-fpm: pool www
Dec 06 12:29:59 localhost.localdomain systemd[1]: Starting The PHP FastCGI Process Manager...
Dec 06 12:30:00 localhost.localdomain systemd[1]: Started The PHP FastCGI Process Manager.
[root@localhost ~]# netstat -ntpl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:9000 0.0.0.0:* LISTEN 2953/php-fpm: maste
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 2897/mysqld
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2946/nginx: master
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1494/sshd
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2651/master
tcp6 0 0 :::22 :::* LISTEN 1494/sshd
tcp6 0 0 ::1:25 :::* LISTEN 2651/master

部署WordPress应用(30分)
48

使用xserver1节点,基于lnmp环境,部署WordPress应用(WordPress源码包在/root目录下)。应用部署完毕后,设置WordPress的站点标题为自己的姓名(例:名字叫张三,则设置站点标题为张三的BLOG),设置完毕后登录WordPresss首页。最后将命令curl ip(ip为wordpress的首页ip)的返回结果以文本形式提交到答题框。

参考答案:

[root@localhost ~]# curl 192.168.100.10
<!DOCTYPE html>
<title>张三 &#8211; 又一个WordPress站点</title>
<p>欢迎使用WordPress。这是您的第一篇文章。编辑或删除它,然后开始写作吧!</p>

Linux存储LVM管理(30分)
49

使用xserver1虚拟机,使用VMWare软件自行添加一块大小为20G的硬盘,使用fdisk命令对该硬盘进形分区,要求分出两个大小为5G的分区。使用两个分区,创建名xcloudvg的卷组并指定PE大小为16 MB。将执行vgdisplay命令的返回结果以文本形式提交到答题框。

参考答案:

[root@localhost ~]# vgdisplay
--- Volume group ---
VG Name centos
System ID
Format lvm2
Metadata Areas 1
Metadata Sequence No 3
VG Access read/write
VG Status resizable
MAX LV 0
Cur LV 2
Open LV 2
Max PV 0
Cur PV 1
Act PV 1
VG Size 19.51 GiB
PE Size 4.00 MiB
Total PE 4994
Alloc PE / Size 4984 / 19.47 GiB
Free PE / Size 10 / 40.00 MiB
VG UUID 2H21hv-L20X-mqhJ-SvzR-crT2-ln9v-jj2gTY
--- Volume group ---
VG Name xcloudvg
System ID
Format lvm2
Metadata Areas 2
Metadata Sequence No 1
VG Access read/write
VG Status resizable
MAX LV 0
Cur LV 0
Open LV 0
Max PV 0
Cur PV 2
Act PV 2
VG Size 9.97 GiB
PE Size 16.00 MiB
Total PE 638
Alloc PE / Size 0 / 0
Free PE / Size 638 / 9.97 GiB
VG UUID dU0pP2-EW9d-6c0h-8tgQ-t1bN-tBIo-FDqfdR

OpenStack Cinder管理(40分)
50

使用VMWare软件启动提供的opensatckallinone镜像,自行检查openstack中各服务的状态,若有问题自行排查。使用Cinder服务,创建名为“ lvm”的卷类型,然后创建一块带“lvm” 标识的云硬盘,名称为 BlockVloume,大小为 2G,查询该云硬盘详细信息。完成后,将cinder show BlockVloume命令的返回结果以文本形式提交到答题框。

参考答案:

[root@xiandian ~]# cinder show BlockVloume
+--------------------------------+--------------------------------------+
| Property | Value |
+--------------------------------+--------------------------------------+
| attachments | [] |
| availability_zone | nova |
| bootable | false |
| consistencygroup_id | None |
| created_at | 2018-01-18T05:04:06.000000 |
| description | None |
| encrypted | False |
| id | 9f685fd4-4f33-4f0c-b70e-467dab381c24 |
| metadata | {} |
| migration_status | None |
| multiattach | False |
| name | BlockVloume |
| os-vol-host-attr:host | xiandian@lvm#LVM |
| os-vol-mig-status-attr:migstat | None |
| os-vol-mig-status-attr:name_id | None |
| os-vol-tenant-attr:tenant_id | 0ab2dbde4f754b699e22461426cd0774 |
| replication_status | disabled |
| size | 2 |
| snapshot_id | None |
| source_volid | None |
| status | available |
| updated_at | 2018-01-18T05:04:10.000000 |
| user_id | 53a1cf0ad2924532aa4b7b0750dec282 |
| volume_type | lvm |
+--------------------------------+--------------------------------------+

OpenStack Glance管理(40分)
51

使用VMWare软件启动提供的opensatckallinone镜像,自行检查openstack中各服务的状态,若有问题自行排查。在xserver1节点的/root目录下存在一个cirros-0.3.4-x86_64-disk.img镜像;使用glance命令将镜像上传,并命名为mycirros,最后将glance image-show id命令的返回结果以文本形式提交到答题框。

参考答案:

[root@xiandian ~]# glance image-show d3663be2-3ebf-443a-b3fc-b3e39bda8783
+------------------+--------------------------------------+
| Property | Value |
+------------------+--------------------------------------+
| checksum | ee1eca47dc88f4879d8a229cc70a07c6 |
| container_format | bare |
| created_at | 2019-10-24T10:16:52Z |
| disk_format | qcow2 |
| id | d3663be2-3ebf-443a-b3fc-b3e39bda8783 |
| min_disk | 0 |
| min_ram | 0 |
| name | mycirros |
| owner | 0ab2dbde4f754b699e22461426cd0774 |
| protected | False |
| size | 13287936 |
| status | active |
| tags | [] |
| updated_at | 2019-10-24T10:16:52Z |
| virtual_size | None |
| visibility | private |
+------------------+--------------------------------------+

OpenStack Neutron管理(40分)
52

使用VMWare软件启动提供的opensatckallinone镜像,自行检查openstack中各服务的状态,若有问题自行排查。在dashboard界面创建云主机外部网络ext-net,子网为ext-subnet,云主机浮动IP可用网段为192.168.200.100 ~ 192.168.200.200,网关为192.168.200.1。创建云主机内部网络int-net1,子网为int-subnet1,云主机子网IP可用网段为10.0.0.100 ~ 10.0.0.200,网关为10.0.0.1。添加名为ext-router的路由器,添加网关在ext-net网络,添加内部端口到int-net1网络,完成内部网络int-net1和外部网络的连通。将执行neutron router-show ext-router命令所返回的结果以文本形式提交到答题框。

参考答案:

[root@controller ~]# neutron router-show 9d0e62e4-6340-4686-8d99-3fc715166302
+-------------------------+-----------------------------------------------------------------------------------------------------------------------------------------------------------------+
| Field | Value |
+-------------------------+-----------------------------------------------------------------------------------------------------------------------------------------------------------------+
| admin_state_up | True |
| availability_zone_hints | |
| availability_zones | nova |
| description | |
| distributed | False |
| external_gateway_info | {"network_id": "49af02fe-8496-4337-9817-eee1a72feef0", "enable_snat": true, "external_fixed_ips": [{"subnet_id": "1e097cb7-9630-418d-bfd1-57e80354b39a", |
| | "ip_address": "192.168.200.3"}]} |
| ha | False |
| id | 9d0e62e4-6340-4686-8d99-3fc715166302 |
| name | ext-router |
| routes | |
| status | ACTIVE |
| tenant_id | 38e4fd41edaf40189d152dda18935b97 |
+-------------------------+-----------------------------------------------------------------------------------------------------------------------------------------------------------------+

Docker安装(30分)
53

使用xserver1节点,自行配置YUM源,安装docker服务(需要用到的包为xserver1节点/root目录下的Docker.tar.gz)。安装完服务后,将registry_latest.tar上传到xserver1节点中并配置为私有仓库。要求启动registry容器时,将内部保存文件的目录映射到外部的/opt/registry目录,将内部的5000端口映射到外部5000端口。依次将启动registry容器的命令及返回结果、执行docker info命令的返回结果以文本形式提交到答题框。

参考答案:

[root@master ~]# docker run -d -v /opt/registry:/var/lib/registry -p 5000:5000 --restart=always --name registry registry:latest
Containers: 33
Running: 16
Paused: 0
Stopped: 17
Images: 22
Server Version: 18.09.6
Storage Driver: devicemapper
Pool Name: docker-253:0-113162281-pool
Pool Blocksize: 65.54kB
Base Device Size: 10.74GB
Backing Filesystem: xfs
Udev Sync Supported: true
Data file: /dev/loop0
Metadata file: /dev/loop1
Data loop file: /var/lib/docker/devicemapper/devicemapper/data
Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
Data Space Used: 3.573GB
Data Space Total: 107.4GB
Data Space Available: 18.72GB
Metadata Space Used: 22.59MB
Metadata Space Total: 2.147GB
Metadata Space Available: 2.125GB
Thin Pool Minimum Free Space: 10.74GB
Deferred Removal Enabled: true
Deferred Deletion Enabled: true
Deferred Deleted Device Count: 0
Library Version: 1.02.158-RHEL7 (2019-05-13)
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: b34a5c8af56e510852c35414db4c1f4fa6172339
runc version: 3e425f80a8c931f88e6d94a8c831b9d5aa481657
init version: fec3683
Security Options:
seccomp
Profile: default
Kernel Version: 3.10.0-1062.7.1.el7.x86_64
Operating System: CentOS Linux 7 (Core)
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.913GiB
Name: master
ID: U4ME:YWV6:WZEK:7R7W:5OLN:MO4A:NVNH:AEPR:L7GE:UD4S:UZOY:GZXQ
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
192.168.70.10:5000
127.0.0.0/8
Live Restore Enabled: false
Product License: Community Engine
WARNING: the devicemapper storage-driver is deprecated, and will be removed in a future release.
WARNING: devicemapper: usage of loopback devices is strongly discouraged for production use.
Use `--storage-opt dm.thinpooldev` to specify a custom block storage device.

Docker运维(30分)
54

使用xserver1节点,上传nginx_latest.tar到xserver1节点中,然后将该镜像打标签,上传至私有仓库。使用xserver2节点,自行安装docker服务,配置xserver2节点使用xserver1的私有仓库,配置完毕后,在xserver2节点拉取nginx_latest.tar镜像。最后将在xserver2上执行docker images命令返回的结果以文本形式提交到答题框。

参考答案:

[root@master ~]# docker images
REPOSITORY TAG IMAGE ID CREATED SIZE
192.168.100.11:5000/nginx latest 94f6bc30fd27 4 seconds ago 126MB

部署Swarm集群(60分)
55

使用xserver1、xserver2节点,自行配置好网络,安装好docker-ce。部署Swarm集群,并安装Portainer图形化管理工具,部署完成后,使用浏览器登录ip:9000界面,进入Swarm控制台。将curl swarm ip:9000返回的结果以文本形式提交到答题框。

参考答案:

[root@master ~]# curl 192.168.100.10:9000
<!DOCTYPE html><html lang="en" ng-app="portainer">
<head>
<meta charset="utf-8">
<title>Portainer</title>
<meta name="description" content="">
<meta name="author" content="Portainer.io">
<div class="row" style="text-align: center">
Loading Portainer...
<i class="fa fa-cog fa-spin" style="margin-left: 5px"></i>
</div>
<!-- !panel -->
</div>
没有账号? 忘记密码?

社交账号快速登录